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Introducing RoboHelp HTML X5 

 
RoboHelp is a Help-authoring program that will help you create and 

manage content in your Help system or standalone knowledge base.  

RoboHelp's features will allow you to put together an attractive and 

streamlined product.  

 

With RoboHelp HTML, you will create a HTML-based Help system.  A 

HTML-based Help system runs locally under one platform—Windows—

and browser—Internet Explorer.  HTML Help is a Windows-only version 

of RoboHelp.  If you need to create a help system that runs on a 

variety of platforms, such as Linux or Macintosh, WebHelp will be a 

more appropriate choice. 

 

This guide will introduce you to some of these features so that you 

can begin working with RoboHelp HTML. 
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Starting RoboHelp and Creating a New Project 

 
You can either start a new project when you open RoboHelp, or you 

can begin a project after RoboHelp is already open.  With both 

methods, you can use the New Project Wizard to get your project 

started quickly.       

 
To start RoboHelp and create a new project 

1. Click the Start button, point to All Programs, point to 

RoboHelp Office, and then click RoboHelp HTML. 

2. After the dialog box appears, click Create a New Project.  The 

New Project box will appear. 

3. Make sure the New tab is selected, and then click HTML Help.   

4. Click OK.  The New Project Wizard box will appear. 

 

5. In the Enter the Title of this Project box, type an appropriate 

title for your project.  Your title will automatically appear in the 

Enter the File Name for the Project box.   

6. If you want to enter a different file name for your project, type 

the appropriate file name in the Enter the File Name for the 

Project box. 

7. Click the Enter the Location for the Project button .  The 

Select the New Project Folder dialog box will appear. 
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8. In the Folders list, click the appropriate folder.   

9. In the Drives: list, click the appropriate drive.  Click OK.   

10. In the Enter the Title of the First Topic: box, type the title of 

your first topic.   

11. Click Finish. 

 

To create a new project while RoboHelp is open 

 
1. On the File menu, point to New, and then click New Project.  

The New Project box will appear. 

2. Make sure the New tab is selected, and then click HTML Help.  

Click OK.  The New Project Wizard box will appear. 

3. Enter the necessary information, and then click Finish. 

 

Now that you have created your new project, your first topic will open 

in the WYSIWIG Editor in the right pane.  In the left pane, the Project 

Manager will open.  The next section will explain these and other 

features in RoboHelp's user interface. 
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Getting to Know RoboHelp 

When you create a new project, RoboHelp will automatically dis-    

play the Project Manager tab in the left pane.  However, you can     

also use the left pane to manage other aspects of your project,      

such as the table of contents, index, and glossary.   

Each tab at the bottom of the left pane gives you access to a different 

type of task: 

 
 

 

                              1           2           3               4              5 

 

1. Project Manager:  Use the Project Manager tab to manage 

topics, style sheets, and images.  It is a project organizer that 

contains topics and other elements of your project in folders.   

2. TOC Composer:  Create a table of contents for your project 

with the TOC Composer. 

3. Index Designer:  Put together an index for your project with 

the Index Designer. 

4. Glossary Designer:  Use this tab to create a glossary for your 

project. 

5. Tools:  Use the Tools tab to use a group of shortcuts to tools, 

such as Multi-File Find and Replace, the Graphics Locator, 

and video tutorial tools. 

 

While the left pane provides options for organizing your whole project 

and its presentation, the right pane focuses on your project content.  

In this pane, you will also use tabs to switch between panes:   

 

 
 

 

                           1                     2                    3                  4 

1. WYSIWYG Editor:  Enter, edit, and view content with the 

WYSIWYG Editor. 

2. TrueCode Editor:  Edit and view your project's HTML code  

with the TrueCode Editor. 

3. Link View:  View the hyperlinks With the Link View tab 
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that  you have added to each of your topics. 

4. Topics List:  View a list of your topics and double click             

a topic to view and edit content with the Topics List. 

 

You can quickly access certain program features with  

RoboHelp's toolbar.  However, toolbar features vary with each         

tab.  For example, when you select the WYSIWYG Editor tab, the View 

Selected Icon  button is available.  When you select the Project 

tab, this button appears dimmed because it is unavailable.   

 

Here are some of the features available on the Project toolbar: 

 

   
 

                             1     2    3       4  5      6           7     8    

 

1. Save All:  Save your project with this button. 

2. Generate Primary Layout:  Use the Generate Primary Layout 

button to generate your final product.  For more about 

generating, see "Wrapping Up Your Project" on page 10. 

3. View Primary Layout: Use the View Primary Layout button to 

view and edit the primary layout of your project after you've 

generated it. 

4. Create a New Topic: Begin a new topic with this button.  You 

can also modify the appearance, title, and other features of 

your new topic. 

5. Spell Check Active Pane: Check your spelling with the Spell 

Check Active Pane button.  

6. Print: Print your project with the Print button. 

7. View Selected Item:  Use the View Selected Item button to see 

what your topic will look like after it's generated. You will not 

need to generate your project to use this feature. 

8. Properties of Selected Item:  View and modify aspects of an 

item, such as its title, appearance, or status with this button  
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You can use the features on the Object toolbar to connect your    

topics and and content:       

 

 
 

                                          1    2    3           4     5 

 

1. Insert Hyperlink or Edit Selected Hyperlink:  With this button, 

you can insert hyperlinks between topics to connect them. 

2. Insert Popup or Edit Selected Popup:  You can add or modify 

popups to images or text with this button.  Popups connect a 

specific item to another item. 

3. Insert Bookmark or Edit Selected Bookmark:  This button 

allows you to add and modify bookmarks.  You can use a 

bookmark to link an item to a specific section of a topic.    

4. Insert RoboDemo Movie: You can create interactive tutorials 

with this feature. 

5. Insert Image or Edit Selected Image:  With this button, you 

can insert and modify screen captures and other images. 

 

With the Formatting toolbar, you can arrange, modify, and organize 

the text in your topics:  

 

 
 

                   1    2       3            4                     5                 6  

 

1. Assign Style Sheet or Create New: With this button, you can 

assign or create style sheets for your text.   

2. Change Font Color:  Use this button to change the color of 

your font. 

3. Change Highlight Color:  Change or apply highlights to your 

text with the Change Highlight Color button. 

4. Apply Bold, Apply Italic, and Apply Underline: With these 

buttons, you can modify the appearance of your text. 

5. Align buttons: Use these buttons to align your text. 

6. Create a Numbered List /Create a Bulleted List: Use these 

buttons to create automatically formatted bulleted or 

numbered lists. 
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Putting Your Project Together 

 

This section will outline the basic steps and procedures         

necessary for quickly putting together a workable project.             

 

To add topics to your project 

 

1. Click the Create a New Topic button .  The New Topic box 

will appear. 

2. Make sure the General tab is selected.   

3. In the Topic Title: box, type an appropriate title for your topic, 

then click OK.   

 

To develop a table of contents 

 

1. Click the TOC tab, and then click the New TOC Book button  

.  The New TOC Book box will appear. 

2. Make sure the General tab is selected.   

3. In the Book Title: box, type an appropriate name for your 

book, then click OK. 

4. Click the New TOC Page button  to add a page to your table 

of contents.  The New TOC Page box will appear. 

5. Make sure the General tab is selected.  In the Page Title: box, 

type an appropriate title for your page, then click OK. 

6. Continue adding pages and books to your table of contents as 

necessary. 

 

To apply styles to your project 

 

1. Click the Assign Style Sheet or Create New button . 

2. Click an appropriate style from the list. 

 

Note  You can change a style by clicking the Format menu, then 

clicking Styles, or by clicking Style Sheets on the Project tab. 
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To add content to your project 

 

1. Click the TOC tab, and then double-click the topic that you 

want   to work with.  The topic will open in the right pane in 

the WYSIWYG Editor. 

2. Type your text in the WYSIWYG Editor.   

 

To add images to your project 

 

1. In the WYSIWYG Editor, click the place where you want to 

insert your image. 

2. Click the Insert Image or Edit Selected Image button .  The 

Image box will appear. 

3. Click the  button to navigate to your image.  The Image 

box will appear. 

4. In the Look In: list, select the appropriate drive.   

5. In the File Name: box, type the name of your file.  Click Open. 

 

To add hyperlinks between your topics 

 

1. In the WYSIWYG Editor, click where you want to insert the 

hyperlink, or select the text that you want to link. 

2. Click the Insert Hyperlink or Edit Selected Hyperlink button 

.  The Hyperlink box will appear. 

3. Under Select Destination (File or URL), click the topic that you 

want to link your text to.  Click OK.   

 

To add an index to your project  

 

1. Click the Index tab, then click the New Index Keyword button 

. 

2. In the Enter New Index Keyword Here box, type a keyword 

from your project, and then press ENTER. 

3. Click the Topics tab to display the Topic List, and then drag a 

topic that relates to your keyword and drop it into the Topics 

For box. 

4. Continue adding dragging and dropping topics into the Topics 

For: box until you are finished. 
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Wrapping Up Your Project 

This section will take you through the steps necessary for         

completing and distributing your project.  The following steps    

explain how to create a browse sequence, generate your            

project, and print your generated product. 

First, you may want to create a browse sequence.  A browse 

sequence will allow your users to navigate your Help system more 

easily and add linearity to your project. 

To create a browse sequence 

1. On the Tools menu, click Browse Sequence Editor. 

2. Click New.   

3. In the Untitled box, type a name for your browse sequence. 

4. To put a topic in a browse sequence, click the topic you want 

to add, then click the  arrow or click and drag the topic you 

want to add to the appropriate browse sequence.  The topic 

will appear under the browse sequence.   

5. Continue creating browse sequences and adding topics until 

you are finished.   

6. Click OK. 

To generate your project 

1. Click the Generate Primary Layout button .  When your 

project has finished generating, the Result: WebHelp Has 

Been Successfully Generated message will appear. 

2. Click View Result to see the final product.   
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Getting Help 

 
RoboHelp's Help system can answer your questions about RoboHelp's 

features and help you use those features.  To access help at any 

time, press F1 or click Contents & Index on the Help menu. 

 

Customer Support 

 
If you are unable to find a solution with Help, Adobe support staff can 

assist you with troubleshooting your computer.  Adobe customer 

support options include: 

 

Customer Service:  800-833-6687 

 Open Monday through Sunday, 6 am-8 pm PST/PDT 

 US and Canada 

 

Technical Support:  800-642-3623 

 Open Monday through Friday, 6 am-5pm PST 

 All regions 

 

You can also search for answers on the Adobe Online Knowledgebase 

at <http://www.adobe.com/support>. 
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